Author Topic: Problem: g.e-hentai  (Read 8981 times)

Moukojin

  • Newbie
  • *
  • Joined: Sep 2010
  • Posts: 35
    • View Profile
Re: Problem: g.e-hentai
« Reply #15 on: September 15, 2010, 10:14:01 AM »
Yes now it works on g.e-hentai and exhentai :D . Arigatou (it's japanese and it mean thanks  :))

web_surfer

  • IHG Disciple
  • Administrator
  • Hero Member
  • *****
  • Joined: Jul 2009
  • Posts: 1300
    • View Profile
    • GitHub account
Re: Problem: g.e-hentai
« Reply #16 on: September 15, 2010, 10:28:10 AM »
Nice  ;)

Rookie

  • Sr. Member
  • ****
  • Joined: Jun 2010
  • Posts: 485
    • View Profile
Re: Problem: g.e-hentai
« Reply #17 on: September 15, 2010, 01:15:32 PM »
Hello both of you,

It's really weird, but I can't use the code written by web_surfer on g.e-hentai.org. I got most of the time the image "403 access denied".
Is it due to the fact I am not logged in ? When I use my code, it works perfectly...

When I try to connect on exhentai.org, I only get a panda ???

Moukojin

  • Newbie
  • *
  • Joined: Sep 2010
  • Posts: 35
    • View Profile
Re: Problem: g.e-hentai
« Reply #18 on: September 15, 2010, 01:25:36 PM »
I try web_surfers script in 18hours ^^.
For exhentai you have to look in the e-hentai Forum because i got the access without changes.
Twitter from exhentai: http://twitter.com/exhentai
Last message: Oh, and if you're getting the Sad Panda error.. you're doing it wrong.
Good night everyone ^^

web_surfer

  • IHG Disciple
  • Administrator
  • Hero Member
  • *****
  • Joined: Jul 2009
  • Posts: 1300
    • View Profile
    • GitHub account
Re: Problem: g.e-hentai
« Reply #19 on: September 16, 2010, 01:56:51 AM »
Haha, I get that panda too  ;D

To Rookie... your code and my code should get the same result. I guess we get the 403 error because they only allow one connection, so we should sleep between one download and the next one. Anyway, I'll test your code to check if I get some 403 image.

web_surfer

  • IHG Disciple
  • Administrator
  • Hero Member
  • *****
  • Joined: Jul 2009
  • Posts: 1300
    • View Profile
    • GitHub account
Re: Problem: g.e-hentai
« Reply #20 on: September 16, 2010, 02:24:24 AM »
Nice results...  ;D

I've discovered the problem. Rookie was right, his code was working fine.
The solution was:

Code: [Select]
replace(/&/g, "&")
And it seems that they actually allow simultaneous connections. I'm testing it with maxThreads=2 and it seems to work fine. I'll test it a little bit more. I'll modify maxThreads in the online host file if everything is OK.

web_surfer

  • IHG Disciple
  • Administrator
  • Hero Member
  • *****
  • Joined: Jul 2009
  • Posts: 1300
    • View Profile
    • GitHub account
Re: Problem: g.e-hentai
« Reply #21 on: September 16, 2010, 02:44:12 AM »
You can access exhentai modifying one cookie...  :P

Rookie

  • Sr. Member
  • ****
  • Joined: Jun 2010
  • Posts: 485
    • View Profile
Re: Problem: g.e-hentai
« Reply #22 on: September 16, 2010, 11:53:46 AM »
Quote
You can access exhentai modifying one cookie...   :P

[Thunderbirds]
Tell me more, tell me more
[Putzie]
But you don't gotta brag


What's the tool you recommand to edit ff cookies ?

web_surfer

  • IHG Disciple
  • Administrator
  • Hero Member
  • *****
  • Joined: Jul 2009
  • Posts: 1300
    • View Profile
    • GitHub account
Re: Problem: g.e-hentai
« Reply #23 on: September 16, 2010, 12:14:31 PM »
I use this one:

https://addons.mozilla.org/en-US/firefox/addon/13793/

You have to set ipb_member_id to "1"  :)

Rookie

  • Sr. Member
  • ****
  • Joined: Jun 2010
  • Posts: 485
    • View Profile
Re: Problem: g.e-hentai
« Reply #24 on: September 17, 2010, 12:03:47 PM »
Nice, thanks.

At first glance I don't really see the difference between g.e-hentai.org and exhentai.org...

Rookie

  • Sr. Member
  • ****
  • Joined: Jun 2010
  • Posts: 485
    • View Profile
Re: Problem: g.e-hentai
« Reply #25 on: September 17, 2010, 01:03:51 PM »
I have tested the new version of script for g.e-hentai.

It works much better but still...

I suggest to invert the two tests

   var iUrl = pageData.match(/img src="(http:\/\/\d+\.\d+\.\d+\.\d+(:\d+)?\/h\/.+?)"/);
   if (!iUrl) iUrl = pageData.match(/img src="(http:\/\/\w+?\.hentaiverse\.net\/[^"]+?image\.php.+?)"/);

The second line is more specific! The first one gets too much match...

   var iUrl = pageData.match(/img src="(http:\/\/\w+?\.hentaiverse\.net\/[^"]+?image\.php.+?)"/);
   if (!iUrl) iUrl = pageData.match(/img src="(http:\/\/\d+\.\d+\.\d+\.\d+(:\d+)?\/h\/.+?)"/);

works better  :)

web_surfer

  • IHG Disciple
  • Administrator
  • Hero Member
  • *****
  • Joined: Jul 2009
  • Posts: 1300
    • View Profile
    • GitHub account
Re: Problem: g.e-hentai
« Reply #26 on: September 18, 2010, 03:03:13 AM »
Yes... but there are more images that match the first line (like 75%), so my option should be faster.

Rookie

  • Sr. Member
  • ****
  • Joined: Jun 2010
  • Posts: 485
    • View Profile
Re: Problem: g.e-hentai
« Reply #27 on: September 18, 2010, 08:53:10 AM »
You are right, but the drawback is that it increases the chances to get a wrong url (not the image you expected).

Moukojin

  • Newbie
  • *
  • Joined: Sep 2010
  • Posts: 35
    • View Profile
Re: Problem: g.e-hentai
« Reply #28 on: October 09, 2010, 04:20:03 AM »
I have problems with exhentai and g.e-hentai  :-\
The pictures can't be found or they download the arrow picutres x_x.
If the pictures can't be found than I have to go to the picture site and have to add a parameter: ?nl=1 (example: http://exhentai.org/s/c1713fa253/250421-20?nl=1)
Example gallery link: http://exhentai.org/g/250421/e9b273405a/
I hope you both can help me.

web_surfer

  • IHG Disciple
  • Administrator
  • Hero Member
  • *****
  • Joined: Jul 2009
  • Posts: 1300
    • View Profile
    • GitHub account
Re: Problem: g.e-hentai
« Reply #29 on: October 09, 2010, 06:17:05 AM »
Those sites are a pain in the ass  >:(
I've updated the host file.